Smarts NCM: Scheduled jobs do not run when expected; Smarts NCM sets the Fire Time for a scheduled job to a different time than what was scheduled by user
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Article ID: 331226
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Updated On:
Products
VMware Smart Assurance
Issue/Introduction
Symptoms:
Smarts NCM scheduled jobs do not run at the expected time.
When scheduling a job in Smarts NCM at a specific time and saving the job, the Fire Time of the job is different that what is expected.
Environment
VMware Smart Assurance - NCM
Cause
The timezone of the user scheduling the job is not the same as the timezone setting of the Smarts NCM server. When setting the schedule of the job, the timezone for the job and the timezone of the servers are the deciding factor. For example, if the server time is 8:00 PM UTC and the job is scheduled to run at 8:23 PM (GMT -5.0) EST, the job Fire Time will be set to 01:23 AM UTC, which is correct as it would be 8:23 PM (GMT -5.0) EST. See the following screenshots:
Schedule Time (User):
Fire Time (Server)
Resolution
To address this issue, ensure the timezone in the Smarts job run options to reflect the server time.