Smarts NCM: Cannot login to GUI following upgrade to NCM 9.4; jboss.remoting.CannotConnectException for port 4446 found in uiClient log
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Article ID: 331222
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Updated On:
Products
VMware Smart Assurance
Issue/Introduction
Symptoms:
Following an upgrade a customer cannot login to NCM 9.4 despite on upgrade issues and all services running OK
The following is seen in the uilcient.log file on the clients machine:
20 Sep 2016 13:51:45,235-[Thread-29] DEBUG org.jboss.remoting.Client - Client[194382499:a2026-v87mhq-itbhch4a-1-itbhchak-3] is connected 20 Sep 2016 13:51:45,258-[Thread-29] DEBUG org.jboss.remoting.transport.socket.SocketClientInvoker - SocketClientInvoker[98179f7, socket://customername.com:4446] org.jboss.remoting.CannotConnectException: Can not get connection to server. Problem establishing socket connection for InvokerLocator [socket://customername:4446/?dataType=invocation&enableTcpNoDelay=true&marshaller=org.jboss.invocation.unified.marshall.InvocationMarshaller&unmarshaller=org.jboss.invocation.unified.marshall.InvocationUnMarshaller]
Environment
VMware Smart Assurance - NCM
Cause
Please note that in 9.4 release jboss is no longer used and also 4446 port is not used.
Resolution
Clear the java cache on machine where you are trying to launch GUI. Relaunch/download the powerup.jnlp again will fix this issue.