Auto Discovery jobs are stuck in running state with the status "queued for execution"
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Auto Discovery jobs are stuck in running state with the status "queued for execution"

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Article ID: 331221

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:

  • The autodisc.log repeats this message:
    Info: Waiting for status file, will try again...
  • Auto Discovery jobs are stuck in running state with the status queued for execution.
  • Only one of the Auto Discovery jobs states that it is executing, but it never finishes.
  • The only jobs stuck in a running state are Auto Discoveries.

Environment

NCM 10.1.X

Cause

The Device Server has requested a new batch of IDXs from the Application Server, but it has failed to synchronize correctly, and is stuck.

Resolution

To resolve this issue, you will need to remove two shadow files and touch a cmd file on the Device Server:

  1. On the Device Server with the problem, change directory to $VOYENCE_HOME/data/devserver/syssync/getidx as follows:
    cd $VOYENCE_HOME/data/devserver/syssync/getidx
     
  2. Remove the two shadow files from the directory as follows:
    rm -f .ssShadow*

This will force a resend of the cmd file and should remove it and replace it with a status file (status_99000001). The autodisc.log will begin to process normally.

 

Additional Information

The variable $VOYENCE_HOME refers to the installed location of NCM, typically /opt/smarts-ncm.