Smarts NCM: Unable to schedule network configuration pulls after migration from 4.11.
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Smarts NCM: Unable to schedule network configuration pulls after migration from 4.11.

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Article ID: 331214

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


High

After migrating to 9.4 from 4.11, you attempt to schedule a job and as soon as you click schedule you immediately get a popup on the screen that you can't schedule the job with an error message "Failed to schedule job with credential org.hibernate.exception.ConstraintViolationException: Could not execute JDBC batch update". You will also see errors in the powerup and server logs as seen below:

Powerup.log from the  $VOYENCE_HOME/ncmcore/logs/ directory:
ERROR [com.powerup.configmgr.server.services.scheduler.ejb.SchedulerServiceBean] (http-nio-8880-exec-1) Failed to schedule job with credential
org.hibernate.exception.ConstraintViolationException: Could not execute JDBC batch update


Server.log from the $VOYENCE_HOME/ncmcore/logs/ directory:
ERROR [com.powerup.configmgr.server.services.scheduler.ejb.SchedulerServiceBean] (http-nio-8880-exec-1) Failed to schedule job with credential org.hibernate.exception.ConstraintViolationException: Could not execute JDBC batch update

Environment

VMware Smart Assurance - NCM

Cause

The cause of this issue has not been determined.

Resolution

To resolve the issue, please upgrade to Network Configuration Manager 9.4.1. This resolves the issue and clears the error messages in the logs.