Smarts NCM: Java client freezing when accessing from jumpbox environment; GUI freezing when using Jumpbox; Other users will still be able to use the application without issue
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Smarts NCM: Java client freezing when accessing from jumpbox environment; GUI freezing when using Jumpbox; Other users will still be able to use the application without issue

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Article ID: 331199

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:




When launching the NCM GUI from a jumpbox environment the GUI will freeze on occasion. Testing will find that some users will still be able to use the application without issue. Further testing will show that opening another GUI session while the frozen session remains open will result in the second session working while the first session remains frozen. Looking at the Application Server there is no performance issues and there is no issues causing this from the Application server.

Environment

VMware Smart Assurance - NCM

Cause

This only happens when accessing the application from a Jumpbox. The issue is an environmental issue when accessing jboss resources. The java cache gets overwhelmed as well as timeout issues are to blame.

Resolution

There is no fix for this, only a workaround that can be applied to resolve or reduce the issue. There are a few steps involved to the work around. 

On the Application Server
  • Backup $VOYENCE_HOME/jboss/server/vc-server/deploy/messaging/remoting-bisocket-service.xml
  • Open $VOYENCE_HOME/jboss/server/vc-server/deploy/messaging/remoting-bisocket-service.xml
  • Locate the parameter (<attribute name="failureDisconnectTimeout" isParam="true">0</attribute> )
  • Modify the 0 to 1000 (This value can be 5000 or 10000 as needed)
  • Locate the parameter <attribute name="pingFrequency" isParam="true">30000</attribute>
  • Modify the 30000 to -1
  • Restart the vcmaster services
On the client jumpbox
  • Ensure that 64bit version of Java is installed and running
  • Clear the java cache
Hold down the Windows Key and press R or go to Start>Run
Type "javaws -uninstall" without quotes, then select "OK".
 

You should see a pause then the cache will then be cleared. No notification will appear to tell you the command was successful. 
You could also run this command from a command prompt. 



Open the browser window to https://<AS_IP>:8880/voyence/powerup.jnlp to download a new copy of the jnlp. (AS_IP= The Application Server IP, hostname or FQDN).
Continue to use the application without freeze issue

Additional Information

In some instances clearing the java cache on a regular schedule may be required. This can be done via the Task Scheduler. 

Open Start > Administrative Tools > Task Scheduler
Create new task        
                                                               

 
Name task and set Security Options  
 
 
 
Create new Trigger              
 
 
Set the trigger
 
 
 
Create New Action
 
       
 
Set Action Details  
 

Set conditions and settings as necessary and press okay to save the task.