Smarts NCM: NCM Console and Server time don't match; error on console: "Client clock is out of sync with the server".
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Smarts NCM: NCM Console and Server time don't match; error on console: "Client clock is out of sync with the server".

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Article ID: 331195

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


The scheduled jobs cannot be run on time

 Smarts NCM GUI Console and Server time don't match; error on console: "Client clock is out of sync with the server":
 


 
When you hover the mouse over the yellow "!" icon at the bottom right hand corner, you see a "Client clock is out of sync with the server" as per screenshot above. 

The icon circled in red shows the 'sync' button.

Double-clicking the clock icon this does not resolve the timing issue between server and console.
     
 
 





Environment

VMware Smart Assurance - NCM

Cause

This issue was caused when changing timezones using Java (/usr/java/jdk1.7.0_45/jre/bin/java) using tzupdate.jar tool

There are two main clocks in a Linux system:

The Hardware Clock: This is a clock that runs independently of any control program running in the CPU and even when the machine is powered off.

The System Time: This is the time kept by a clock inside the Linux kernel and driven by a timer interrupt. It has meaning only while Linux is running on the machine.

Often-times, it happens that when you reboot, your clock does not reflect the correct date and time. You may be forgetting to sync the hardware clock with the current system time.

The NCM application looks to the System Time to sync with the client machine.

Resolution

First check and set the current system date and time using the following commands:

Check the date and time:
# date
Fri May 30 19:14:29 EDT 2014

Set the date and time:
# date -s 'Mon Oct 27 05:08:38 PM EDT 2014'

Now you will need to sync your hardware clock with the system time.

To check what is stored in the clock:
# hwclock --show

To sync your hardware clock with the system time:
# hwclock -systohc

Once everything is in sync, open the NCM GUI Console and in the bottom left hand corner where the time information is, click the little button that looks like the clock with a red arrow above it. This will update the session to reflect the changes. It should now be in sync and look like the following.



Additional Information

You can also set the date using ntpdate with the following command:

#ntpdate pool.ntp.org

If it complains about socket in use, then stop ntpd and run the ntpdate again.