Smarts NCM: Cisco config pulls are randomly not completing
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Article ID: 331185
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Updated On:
Products
VMware Smart Assurance
Issue/Introduction
Symptoms:
Customers experience configurations that will randomly not finish downloading into NCM (Network Configuration Manager). It will appear that some Cisco Nexus configurations will be more complete than others with no consistency. The Pull job will also state that it successfully completed the job.
Environment
VMware Smart Assurance - NCM
Cause
This is caused by customers using '#' to add descriptions on interface lines on the inside configuration of a Cisco Nexus Device.
Here is part of a Cisco Nexus config:
interface Ethernet150/1/1 description testdns03-a-lan1 192.168.46.176, SD #9014738, Joe Test DNS switchport access vlan 121
Resolution
The provided patch will only resolve issues with the Cisco Nexus device. Please complete the following directions to resolve the issue.
Log into the CLI of the Device Server or Combo Server that communicates with the Cisco Nexus device.
Source /etc/voyence.conf
Download the attached nexusPrompt.tar file to a temp location.
Untar the nexusPrompt.tar file in the $VOYENCE_HOME/custompackage/ directory.
You should have a pkgxml/CiscoNexus/CiscoNexusPrompts.xml file in the $VOYENCE_HOME/custompackage/ directory.
Complete a device server restart (service voyence restart) to have the patch applied.
Test and confirm the provided patch resolved the issue.