Unable to login to Cisco CatOS Swtich.
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Unable to login to Cisco CatOS Swtich.

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Article ID: 331166

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Customers will not able to log into Cisco CatOS devices and will experience the following error messages in the session and commmgr logs:

/telnet#1: RCV-1007>% Authentication failed.

DASL: termLogin: WARNING - Telnet No Login or Device Prompt detected


It will appear to the customer that NCM is providing the wrong password to the Cisco CatOS device. 







Environment

VMware Smart Assurance NCM 10.X

Cause

NCM is looking to match "Username" as the login prompt with no compensation for upper case letter in the first position . The Cisco CatOS uses "username" as the login prompt as shown below:


RCV-1007>username:

Resolution

Do the following below steps to resolve the problem.

  • Log into your Device Server via CLI that is connection to the Cat OS Switch
  • Source the voyence.conf file with the below command:
Source /etc/voyence.conf
  • Check and see if the following directory exists, and if not then create it (note, it must be with the capital letters like below):
$VOYENCE_HOME/custompackage/pkgxml/CiscoCatOSSwitch/ 
  • Then utilize the following copy command:
cp $VOYENCE_HOME/package/pkgxml/CiscoCatOSSwitch/CiscoCatOSSwitchPrompts.xml  $VOYENCE_HOME/custompackage/pkgxml/CiscoCatOSSwitch/CiscoCatOSSwitchPrompts.xml
  • Then run the following VI command:
vi $VOYENCE_HOME/custompackage/pkgxml/CiscoCatOSSwitch/CiscoCatOSSwitchPrompts.xml
  • Search for the following line
<Expr><![CDATA[ ?Username ?:|[Ii][Dd]:]]></Expr>
  •  Change "Username" to "[Uu]sername" the line should look like:
<Expr><![CDATA[ ?[Uu]sername ?:|[Ii][Dd]:]]></Expr>
  • Save and Exit. 
  • Complete a device server restart: service voyence restart
  • Test and confirm that you can now log into the device.