Smarts NCM: Unable to login to Cisco CatOS Swtich.
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Smarts NCM: Unable to login to Cisco CatOS Swtich.

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Article ID: 331166

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


Customers will not able to log into Cisco CatOS devices and will experience the following error messages in the session and commmgr logs:

/telnet#1: RCV-1007>% Authentication failed.

DASL: termLogin: WARNING - Telnet No Login or Device Prompt detected


It will appear as to the customer that NCM is providing the wrong password to the Cisco CatOS device. 







Environment

VMware Smart Assurance - NCM

Cause

NCM is looking to match "Username" as the login prompt with no compensation for upper case letter in the first position . The Cisco CatOS uses "username" as the login prompt as shown below. 


RCV-1007>username:

Resolution

Do the following below to resolve the problem.
  1. Log into your Device Server via CLI that is connection to the Cat OS Switch
  2. Source /etc/voyence.conf
  3. Check and see if the following directory exists if not then create it: $VOYENCE_HOME/custompackage/pkgxml/CiscoCatOSSwitch/ (Must be exact with capital letters)
  4. cp $VOYENCE_HOME/package/pkgxml/CiscoCatOSSwitch/CiscoCatOSSwitchPrompts.xml  $VOYENCE_HOME/custompackage/pkgxml/CiscoCatOSSwitch/CiscoCatOSSwitchPrompts.xml
  5. vi $VOYENCE_HOME/custompackage/pkgxml/CiscoCatOSSwitch/CiscoCatOSSwitchPrompts.xml
    • Search for the following line <Expr><![CDATA[ ?Username ?:|[Ii][Dd]:]]></Expr>
  6. Change "Username" to "[Uu]sername" the line should look like:
    • <Expr><![CDATA[ ?[Uu]sername ?:|[Ii][Dd]:]]></Expr>
  7. Save and Exit. 
  8. Complete a device server restart: service voyence restart
  9. Test and confirm that you can now log into the device.