Smarts NCM: Unable to login to Cisco CatOS Swtich.
book
Article ID: 331166
calendar_today
Updated On:
Products
VMware Smart Assurance
Issue/Introduction
Symptoms:
Customers will not able to log into Cisco CatOS devices and will experience the following error messages in the session and commmgr logs:
/telnet#1: RCV-1007>% Authentication failed.
DASL: termLogin: WARNING - Telnet No Login or Device Prompt detected
It will appear as to the customer that NCM is providing the wrong password to the Cisco CatOS device.
Environment
VMware Smart Assurance - NCM
Cause
NCM is looking to match "Username" as the login prompt with no compensation for upper case letter in the first position . The Cisco CatOS uses "username" as the login prompt as shown below.
RCV-1007>username:
Resolution
Do the following below to resolve the problem.
Log into your Device Server via CLI that is connection to the Cat OS Switch
Source /etc/voyence.conf
Check and see if the following directory exists if not then create it: $VOYENCE_HOME/custompackage/pkgxml/CiscoCatOSSwitch/ (Must be exact with capital letters)