Smarts NCM : Unable to login to Report Advisor after fresh installtion of Smarts NCM 9.4
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Smarts NCM : Unable to login to Report Advisor after fresh installtion of Smarts NCM 9.4

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Article ID: 331137

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:




After fresh installation of Smarts NCM 9.4 , unable to login to Report Advisor

Environment

VMware Smart Assurance - NCM

Cause

 The Smarts NCM Report Advisor doesn t come up after a fresh installation unless its either connected to live Internet or has some files copied in a particular path from www.springframework.org website.

Resolution

This issue has been resolved in Smarts NCM 9.4.0 Patch 1.

Please upgrade this to release to attain the fix.

Patch 1 ReadMe

If you are unable to upgrade, please use the workaround below:

For users operating in a dark site without internet connection, the following steps need to be performed to bring the RA up and running :

1. Download spring-beans-2.5.jar.zip from http://www.java2s.com/Code/Jar/s/Downloadspringbeans25jar.htm using host with active internet connection

2. Unzip the downloaded file and copy spring-beans-2.5.jar file under $TOMCAT_HOME/webapps/web/WEB-INF/lib

3. Ensure that the permissions for copied spring-beans-2.5.jar file are tomcat:tomcat abd 0640

4. Restart tomcat service with the command "service tomcat restart"