Smarts NCM: Error in the change config details report in the Report Advisor - "ERROR: CANNOT DECRYPT CONFIG DIFFERENCE - CHECK ACCESS TO LOCKBOX/EKEY"
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Smarts NCM: Error in the change config details report in the Report Advisor - "ERROR: CANNOT DECRYPT CONFIG DIFFERENCE - CHECK ACCESS TO LOCKBOX/EKEY"

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Article ID: 331129

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


  • On the Smarts NCM Report Advisor (RA), generating the change config details report with below error:
ERROR: CANNOT DECRYPT CONFIG DIFFERENCE - CHECK ACCESS TO LOCKBOX/EKEY 
  • Unlocking the lockbox on the RA server does not resolve the issue: 
$VOYENCE_HOME/bin/cstdriver -lockbox /opt/smarts-ncm/data/lockb.clb -passphrase <PASSPHRASE>


Environment

VMware Smart Assurance - NCM

Cause

The permission of the $VOYENCE_HOME/data/lockb.clb lockbox file is set to "root:root" and not the default "root:cst" (where the user permission is set to "root" and the group permission is set to "cst"):
 
[root@ncm941 data]# pwd
/opt/smarts-ncm/data
[root@ncm941 data]# ls -l lockb.clb
-rw-r----- 1 root cst 3514 Sep 12 14:45 lockb.clb

 

Resolution

To resolve this issue, refer to the following steps:
  1. Login to the Report Advisor (RA) server as "root".
  2. Change the permissions for the $VOYENCE_HOME/data/lockb.clb lockbox file to "root:cst":
[root@ncm941 data]# chown root:cst lockb.clb
  1. Restart tomcat on the RA server. This will resolve the decrypt configuration error on the RA report generation.