Smarts NCM: How to view SNMP credentials inside a configuration file. Why can some users see the SNMP credentials while others cannot.
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Smarts NCM: How to view SNMP credentials inside a configuration file. Why can some users see the SNMP credentials while others cannot.

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Article ID: 331117

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


The ability to view SNMP community strings located on a configuration file inside NCM. 

Customers might view configuration files and will see a difference as some users can view the SNMP community strings and some users can't view the SNMP community string. Please see the screen shots below:

In this screen shot the user will only see a bunch of numbers and letters, where the SNMP community strings should be, they are encrypted.   This is normal as the user does not have the rights to view passwords in the configuration. 


Below you can see the user is able to view the SNMP community strings and credentials. This is normal for a Sysadmin user to see the community strings credentials as they are unencrypted.   




Environment

VMware Smart Assurance - NCM

Cause

This is by design and provides custom levels of security. This can be adjusted based on a user or group.

Resolution

To enable non-sysadmin users to have rights to view the Community String Credentials you must check "View Sensitive Data" under either the "Default Network" or the network you created.  "Users" or "Groups" can be given these rights. Please follow the directions and view the screen shot below to make the changes:

Go to System Administration (F4)
----> Expand "Global"
----> Expand "User Management"
----> Select either "Users" or "Groups"
----> Select or highlight the "User" or "Group" you wish to change permissions on
----> Click on "Permissions"
----> Expand "Network Permissions"
----> Select the Network you would like the User or Group to have the ability to view the unencrypted Community Strings
----> Under "Device" check "View Sensitive Data".
Apply and close the rest of the Windows.

Test by logging out of NCM and logging into NCM as that user.