Smarts NCM: Report Advisor jobs show "FAILED" in the Job Status column
search cancel

Smarts NCM: Report Advisor jobs show "FAILED" in the Job Status column

book

Article ID: 331102

calendar_today

Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


Customer might experience the following:



The /user/tomcat/apache[version]/logs/Voyence.log will have the following error message:

Caused by: java.lang.RuntimeException: org.postgresql.util.PSQLException: ERROR: could not write to hash-join temporary file: No space left on device

Sever.postmaster has the following error:

SessionId:59cbeaef.3c62 - TransId:0 - ERROR: could not write block 2996616 of temporary file: No space left on device......

However after an analysis of the Application Server or Database Server you find there is plenty of available disk space. 

Environment

VMware Smart Assurance - NCM

Cause

Report ran out of disk space while trying to complete. Some reports do require a lot of temporary disk space to complete and in extreme some cases it will consume all available space in the $VOYENCE_HOME/opt directory, but when the report finishes by either failing or completing all the pgsql_temp files will be removed and the available disk space will return to normal. This explains why after a failed report, users don't see a disk space issue.

Resolution

To resolve this issue increase the amount of available disk space in the $VOYENCE_HOME/opt directory.