"controldb" service fails to start when vcmaster start command is executed; Lock file contention indicated in /controldb/server.postmaster file
book
Article ID: 331089
calendar_today
Updated On:
Products
VMware Smart Assurance
Issue/Introduction
Symptoms:
Smarts Network Configuration Manager (Smarts NCM) or Voyence controldb service fails to start when service vcmaster start command is executed
Lock file contention is indicated in the /var/logs/controldb/server.postmaster file for Smarts NCM or VoyenceControl environment by the following entry:
TransId:0 - FATAL: could not open lock file "/tmp/.s.PGSQL.5435.lock": Permission denied
Environment
NCM 10.1.X
Cause
This issue occurs because the /tmp subdirectory of the root directory ( / ) does not have the required permissions for Smarts NCM/Voyence to function correctly.
Resolution
If you encounter this issue, you need to change the permissions and owner of the folders back to the user and group they belong, as well as giving the correct access permissions. This is done as follows:
Log into the Smarts NCM or Voyence App server as root user.
From the root directory ( / ), run the following commands:
chown root:root tmp chmod 777 tmp
The commands in the preceding step should set the permissions for the /tmp directory appropriately for Smarts NCM/Voyence to function correctly. To confirm that the settings are now correct, run ls -la on the /tmp directory. The output for this command on the /tmp directory should look like the following: drwxrwxrwx # root root #### <Month> <day> <time> tmp
Where # and #### may vary from system to system and <Month> <Day> <time> are the time stamp that the folder was last modified.