Smarts NCM: Healthcheck functionality not working; Error: sh: /opt/smarts-ncm/Healthcheck/cmstatus: Permission denied
search cancel

Smarts NCM: Healthcheck functionality not working; Error: sh: /opt/smarts-ncm/Healthcheck/cmstatus: Permission denied

book

Article ID: 331074

calendar_today

Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


Unable to run the Healthcheck in Smarts NCM:



The healthcheck page (/voyence/HealthCheckStatus.html) contains an error message:

Mon Nov 17 13:16:43 2014 - INFO: Health Check server starting up
Mon Nov 17 13:16:43 2014 - INFO: Found Device Server 1000 (x.x.x.x, devicename)
Mon Nov 17 13:16:43 2014 - INFO: Running task 0114162302030000 on device server 1000 (x.x.x.x)
Mon Nov 17 13:16:49 2014 - RESULTS: Results for POP 1000 ---------------------
Mon Nov 17 13:16:49 2014 - RESULTS: 0:Running...
Mon Nov 17 13:16:49 2014 - RESULTS: 1:Results Begin
Mon Nov 17 13:16:49 2014 - RESULTS: 4:sh: /opt/smarts-ncm/Healthcheck/cmstatus: Permission denied
Mon Nov 17 13:16:49 2014 - RESULTS: 4:    
Mon Nov 17 13:16:49 2014 - RESULTS: 1:Results End
Mon Nov 17 13:16:49 2014 - RESULTS: 99:DASLlet complete
Mon Nov 17 13:16:49 2014 - INFO: Task 0114162302030000 completed on device server 1000 (x.x.x.x) in 5 seconds
Mon Nov 17 13:16:49 2014 - INFO: Device Server 1000 queue count = 0
Mon Nov 17 13:16:49 2014 - INFO: Waiting 295 seconds for the next iteration of checks.
Mon Nov 17 13:21:44 2014 - INFO: Found Device Server 1000
Mon Nov 17 13:21:44 2014 - INFO: Running task 0114162305040000 on device server 1000 (x.x.x.x)


The GUI shows:

Summary for: devicename

sh:  /opt/smarts-ncm/Healthcheck/cmstatus:  Permission denied

Environment

VMware Smart Assurance - NCM

Cause

This is caused by insufficient permissions for the cmstatus file

Resolution

This issue has been fixed in NCM 9.4 patch 1 (9.4.0.1).

Please upgrade to this version to attain the fix