Smarts NCM: Device Server installation failed with error: Timeout exceeded waiting for server configuration to sync; The server registration process failed. Verify that the Apache HTTP Server is running and listening on both TCP 80 and TCP 443
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Smarts NCM: Device Server installation failed with error: Timeout exceeded waiting for server configuration to sync; The server registration process failed. Verify that the Apache HTTP Server is running and listening on both TCP 80 and TCP 443

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Article ID: 331073

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


Unable to complete installation of Smarts NCM

Below is an error snippet of this issue from the daemon logs :

<body class="normal" bgcolor="#FFFFFF">
<H1>Setup Manager: Review Actions</H1>
<p>The following actions were performed:</p>
<ol><li>Stopping Device Server Daemons...</li><li><font color="red">Can't create IDX for this server: Error: HTTP Error: Remote connection failed: Connection timed out</font></li><li>Starting Device Server Daemons...</li></ol><p><font color="red">An error has occurred.</font> Please click your browser "back" button
to correct the error. To restart setup, click "Setup" below. If the problem continues to
occur, please contact Customer Support.</p>
<form method="POST" name="Setup">
    <input type="submit" name="Script" value="Setup" onClick="window.location='/voyence-bin/setupmgr.cgi';return false;">
</form>
<table border="0" width="100%">
    <tr>
        <td>
            &copy;2008 <a target="_blank" href="http://www.voyence.com">Voyence</a>        </td>
        <td align="right" valign="bottom">
            <font size="2">Version ==version==.==build==</font>
        </td>
    </tr>
</table>
</body>
</html>
Stopping voyence service
Starting service voyence
0 :Waiting for sync...
1 :Waiting for sync...
2 :Waiting for sync...
3 :Waiting for sync...
4 :Waiting for sync...
 
ERROR: Timeout exceeded waiting for server configuration to sync.
ERROR: The server registration process failed.  Verify that the Apache HTTP Server is running and listening on both TCP 80 and TCP 443.
 
Mar 16 04:15:32 -281663520#1: llPROF: check1 after setup milli 0, secs 0
Mar 16 04:18:41 -281663520#1: Connect failed: Connection timed out
Mar 16 04:18:41 -281663520#1: HTTP Error: Remote connection failed: Connection timed out
Mar 16 04:18:41 -281663520#1: Error: Configuration can't be set
Mar 16 04:18:41 -281663520#1: Error: HTTP Error: Remote connection failed: Connection timed out
Mar 16 04:18:41 -281663520#1: Starting Voyence Control!...
Mar 16 04:18:41 setupmgr#1| 5204: -------- setupmgr: stopped 9.3.0.0.106 --------
 
 
Copying /tmp/lockb.clb /apps/smarts-ncm/data/
==> Retrieving the test secret...
Error: Lockbox Access Error: The system hostname key is missing from the Lockbox.
Resolution:Lockbox Access Error: Please check the lockbox access on this server, Please refer to the NCM troubleshooting guide for possible resolution.

Environment

VMware Smart Assurance - NCM

Cause

Smarts NCM installation fails due to tcp ports 80 and 443 being occupied by other processes.

Resolution

We need to free tcp ports 80 and 443 before proceeding with the installation.

Use to following command to check the 

netstat -anpt | grep <port

For instance port 80:

netstat -anpt | grep 80

tcp        0      0 :::80                       :::*                        LISTEN      4382/httpd

In this case the pid which is using port 80 is 4382