Smarts NCM : Unable to launch Report Advisor after new installation; localhost.log has error: java.security.cert.CertificateException: No name matching FQDN found
search cancel

Smarts NCM : Unable to launch Report Advisor after new installation; localhost.log has error: java.security.cert.CertificateException: No name matching FQDN found

book

Article ID: 331051

calendar_today

Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


Unable to launch Report Advisor

Getting "http status 404" error while launching Report Advisor even though the steps to export/import SSL certificate (KB https://support.emc.com/kb/90693) have been properly followed

After checking in the localhost.log under $TOMCAT_HOME/logs, the following error message was found-

Caused by: javax.net.ssl.SSLHandshakeException: java.security.cert.CertificateException: No name matching server1.corp.example.com found

Environment

VMware Smart Assurance - NCM

Cause

Did NSlookup of AS IP on RA machine, the DNS server returns FQDN:
[root@RA logs]# nslookup <AS IP address>
Server: xx.xx.xx
Address: xx.xx.xx.xx#53

xx.xx.xx.xx.in-addr.arpa name = server1.corp.example.com.
[root@RA logs]#

Due to this as part of the Report Advisor installation, web.properties file is populated with FQDN for the *Invoker servlets* and Application Server certficiate has only hostname(not FQDN), hence Report Advisor is failing to communicate with AS's jboss.

Resolution

Edit the web.properties file located at <Basedir>/smarts-ncm/web/conf and replace FQDN with hostname of AS(edited server1.corp.example.com to server1) in below 3 entries values and restart tomcat service. 

java.naming.provider.url
voyencecontrol.ejb_invoker_servlet_path
voyencecontrol.jmx_invoker_servlet_path

Ex: Change server1.corp.example.com to server1 in highlighted entries.



This would resolve the communication issue and launch RA as expected.