Smarts NCM: Pull config fails with "SSH keys did not match"
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Smarts NCM: Pull config fails with "SSH keys did not match"

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Article ID: 331038

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


Pull config fails on any device with "SSH keys did not match" :
 

Receive the following VoyenceControl error message:

ssh_connect():SSH keys did not match

Receive the following error in Smarts NCM:

SSH authentication failed



Environment

VMware Smart Assurance - NCM

Cause

Somehow the SSH keys of device and NCM server have gone out of sync. (or) 
A stale SSH key remains in the NCM server cache for the device. (or) 
Hardware was added, removed or replaced on the device.




Resolution

The solution to this is to delete the stale ssh key from NCM server as follows

The device keys will contain the IP address from the error. Delete those device keys from the below registry keys and perform pull config job.

On Windows:
1) Open regedit from the Command->Run prompt :

2) Then go to the following location:
HKEY_LOCAL_MACHINE\SOFTWARE\Voyence\Control\SshHostKeys

as per example: 


On Linux:
1. Go to the following directory as root
/root/.ssh
2. In this directory there is a file called known_hosts which contains the key data for each host/IP
3. To remove the key for the IP in the error, run the following command :
 
               ssh-keygen -R <ip address>

so for example, it would look like : 

               ssh-keygen -R 10.44.66.77