Smarts NCM: Report Advisor crashes when running large reports with Network Adviser installed.
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Smarts NCM: Report Advisor crashes when running large reports with Network Adviser installed.

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Article ID: 331034

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


Smarts NCM Report Advisor crashes, possible heap dump.

The following conditions, events or system behaviors may be observed with this issue:
  • Running large reports in Smarts NCM Report Advisor with Network Advisor installed and running vulnerability scans is causing Report Advisor to crash.
  • The Network Advisor vulnerability scan jobs are not displayed under Job Manager in Scheduled Scans, and it appears there are no jobs running in Network Advisor.


Environment

VMware Smart Assurance - NCM

Cause

Network Advisor will automatically run vulnerability scans for all the network devices in the environment. This will place an additional load on the Report Advisor server, and can cause a heap dump and crash.

Resolution

To address this issue, disable any Network Advisor vulnerability scans that are not necessary to limit the load on Report Advisor created by the scans. This is done as follows:
  1. Log into Smarts NCM Report Advisor.
  2. In the top right corner, select Network Advisor.
  3. In the left column, select "Vulnerability Scans".
  4. In the main screen search section, search for devices that have been installed to your network. An effective way to do this is to search by device class.
  5. Select the vulnerability you wish to disable.
  6. With the vulnerability selected, select the "Disable" icon on the right side. This is the first "x" from left to right in the following example:
  1. Select "Disable" before moving on to the next page.
  2. Once this is completed, the vulnerability scan will be disabled and there is no need to restart any sevices.