Smarts NCM: Partial config pulled for Nexus devices
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Smarts NCM: Partial config pulled for Nexus devices

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Article ID: 331029

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


Partial config pulled for Nexus 5k model devices. Following error is seen in commmgr.log w.r.t running config of Nexus 5596 device:

Oct 11 06:52:32 -564185344/pull(9967882)#1: State match:[1001][01;34m[(?!\*)(?!#)^\S+#\s*(?!#)][00m 1 5~~no logging console~~~~~~~[01;34m[CHC-001-COSW-002# ][00mshow running-config~~~

Environment

VMware Smart Assurance - NCM

Cause

There's a prompt mismatch between the device configuration and NCM regex for EnablePromptState. 

Resolution

Please implement the modified CiscoNexusPrompts.xml file attached to the article using the below steps:
  1. Make the following directories in NCM Device Server installation if it doesn't already exist.
    • $VOYENCE_HOME/custompackage/pkgxml/CiscoNexus
  2.    Copy the attached CiscoNexusPrompts.xml file to $VOYENCE_HOME/custompackage/pkgxml/CiscoNexus directory
  3. Perform a service voyence restart.
  4. Clear the cache for the Nexus devices and run a pull config job.
  5. If the entire config is not shown post step 4, please proceed to delete the devices and discover it again in NCM & perform a pull operation.  


Attachments

CiscoNexusPrompts.xml get_app