VoyenceControl: Why do I receive an "Invalid Mechanism Unspecified" error when pulling certain devices?
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Article ID: 331027
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Updated On:
Products
VMware Smart Assurance
Issue/Introduction
Symptoms:
Why do I receive an "Invalid Mechanism Unspecified" error when pulling certain devices?
Pull of device configurations fails with the following error:
The selected mechanism does not support pull.
ERR:Invalid Mechanism Unspecified
Environment
VMware Smart Assurance - NCM
Cause
These devices do not have the proper In-Band Communcation mechanism configured, or not do not have a mechanism configred at all
Resolution
To resolve this issue, the following steps need to be taken within VoyenceControl.
- Right-click on one of these devices in the network view and go to Properties
- Click on the Communication tab
- Observe what mechanism is configured here under Communications > In-Band > Management > Mechanism
- Click on the Update Credentials button to change this mechanism to one that the device will accept
Feedback
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