"Invalid Mechanism Unspecified" error during pull or cut-thru
search cancel

"Invalid Mechanism Unspecified" error during pull or cut-thru

book

Article ID: 331027

calendar_today

Updated On:

Products

VMware Smart Assurance

Issue/Introduction

When user performs pull or cut-thru to device from NCM GUI, error below is observed:

The selected mechanism does not support pull.
ERR:Invalid Mechanism Unspecified

Environment

NCM - 10.1.x

Cause

These devices do not have the proper In-Band Communication mechanism configured, or not do not have a mechanism configured at all.

Resolution

  • Right-click on one of these devices or problematic device in the network view and go to Properties
  • Click on the Communication tab.
  • Observe what mechanism is configured here under Communications --> In-Band --> Management --> Mechanism
  • Click on the Update Credentials button to change this mechanism to one that the device will accept or configured on device.

Now perform pull or cut-thru after clearing the cache and it would work.