Smarts NCM: The time displayed in the Last Attempted Comm and Last Successful Comm fields is not correct
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Smarts NCM: The time displayed in the Last Attempted Comm and Last Successful Comm fields is not correct

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Article ID: 330991

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


Smarts NCM reporting may be incorrect by hours based on the timezone differences. This issue does not affect Smarts NCM application performance.

The following conditions, events or system behaviors may be observed with this issue:
  • The time is displayed incorrectly in the Smarts NCM "Last Attempted Comm and Last Successful Comm" fields. 
  • The time is correctly displayed in the Smarts NCM "properties" dialog box under the "Audit" tab. 
  • The "Creation time" in the Audit section on the right side of the "Audit" tab displays the correct time in the US Eastern Timezone.


Environment

VMware Smart Assurance - NCM

Cause

This issue was observed in an environment under the following conditions:
  • The application/database server is located in the Eastern time zone.
  • There are two device servers -- one is in the Eastern Zone and the other is in the Pacific Time zone.
  • The Smarts NCM Console session is in the Central Time zone. 
  • For a device managed by the Pacific Time zone device server the"Last Attempted Comm and Last Successful Comm." time is showing 5:48:PM. However, current time is 2:48PM Central Time.

Resolution

Network Configuration Manager 9.4 Series = The bug is present. The fix would be part of next release, v9.4.2 SP1.

Network Configuration Manager 9.2.2a and 9.3 Series =  The bug is not present, no patch or upgrade is required.