Smarts NCM: Cut-Thru session via ssh keeps timing out after establishing successfully to the device from NCM console.
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Smarts NCM: Cut-Thru session via ssh keeps timing out after establishing successfully to the device from NCM console.

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Article ID: 330983

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


After establishing a successful cut-thru session to the device from the NCM console, If you leave the session open, without actively typing anything, the session gets disconnected.

Environment

VMware Smart Assurance - NCM

Cause

This is the default behaviour of a telnet or ssh session. It will disconnect after idle time has passed.

Resolution


When using ssh as the cut-thru mechanism, to make sure you are not disconnected, follow these steps:

If you have administrative access to the SSH servers, you can change the options so that you will not easily be disconnected.


1. Edit the SSH server configuration file (normally in  /etc/ssh/sshd_config for Unix based operating systems) and set the related options as the followings (uncomment or add if necessary);
 
TCPKeepAlive no
ClientAliveInterval 30
ClientAliveCountMax 100

 
2. What it basically means is that the server will not send the TCP alive packet to check if the client's connection is working, yet will still send the encrypted alive message every 30 seconds but will only disconnect after 24 hours of inactivity.

3. Be sure to restart the SSH service after the reconfiguration. The following command would work for most Unix based servers;
 
sudo service sshd restart