Class for the root element 'audit-trail' could not be found
book
Article ID: 330976
calendar_today
Updated On:
Products
VMware Smart Assurance
Issue/Introduction
NCM class for the root element 'audit-trail' could not be found, thereby consuming the catalina.out log in the following
/usr/tomcat/apache-tomcat-6.0.36/logs
The cm_device_audit_history table in the database is referencing 'audit-trail' which does not exist.
Environment
NCM 10.1.X
Cause
The proper syntax for this root element is AuditTrail
Resolution
To address this issue, do the following:
Log into the database on the application server or database server (if the database is on a standalone server):
su - pgdba
psql voyencedb voyence
Password for user voyence:
Run the following select statement:
select cm_device_audit_history.compliance_audit_trail,encode(cm_device_audit_histo ry.history_id,'hex') from cm_device_audit_history where cm_device_audit_history.compliance_audit_trail LIKE '%audit-trail%';
To redirect the output to a file, execute the following command sequence:
\pset pager
\o /tmp/audit-trail.txt
select cm_device_audit_history.compliance_audit_trail,encode(cm_device_audit_history.history_id,'hex') from cm_device_audit_history where cm_device_audit_history.compliance_audit_trail LIKE '%audit-trail%';
\o
\pset pager
The above command set will turn off page breaks, redirect the output to /tmp in a file called 'audit-trail.txt',and restore standard output after the select statement is finished. You will not see any output to the screen, but the prompt will return once the command has executed. When the command prompt returns, exit the database:
\q
exit
View the file that you have created. You will see an entry or entries similar to the following:
To change the entry or entries, use the 'UPDATE' statement:
Once the entry is updated, restart Smarts NCM services.