Smarts NCM: Jboss service not starting; No errors in Jboss.log or powerup.log
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Smarts NCM: Jboss service not starting; No errors in Jboss.log or powerup.log

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Article ID: 330971

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


Smarts NCM application cannot function normally without JBOSS service running. 

Jboss service not starting so the Smarts NCM application is not functioning properly.

No current time stamp logs will be found in the Jboss.log, powerup.log or server.log. 

To check the current status of JBOSS, run either of the following commands:

a.) service vcmaster status
b.) service jboss status

Environment

VMware Smart Assurance - NCM

Cause

Wrong memory setting in boss.conf file.

Resolution

Please review the /etc/jboss.conf file and confirm that the memory settings are correct as shown below:

JAVA_OPTS="-server -Xms4500M -Xmx4500M

If any of the following below will cause NCM not to launch and not display any logs.  
  • Missing a "M" from Xmx4500M
  • Not enough "0"'s from Xmx4500M
  • If the Xms setting is higher than the Xmx setting.
  • If the Xmx setting is higher than the system memory
Once the setting is corrected, complete a service vcmaster restart and test.