Smarts NCM: Jboss log contains many "Authentication exception, principal=controlDaemon" messages
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Smarts NCM: Jboss log contains many "Authentication exception, principal=controlDaemon" messages

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Article ID: 330965

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


Smarts NCM jboss.log filled with authentication exception messages, making it difficult to read logs.

The following conditions, events or system behaviors may be observed with this issue:
  • The following message is seen many times in Smarts NCM Jboss log (/opt/smarts-ncm/jboss/server/vc-server/log/jboss.log):
2013-11-10 10:13:13,256 TRACE [org.jboss.ejb.plugins.LogInterceptor] (http-0.0.0.0-8881-1) SecurityException in method: public abstract com.powerup.configmgr.server.services.cel.ejb.CelServiceRemote com.powerup.configmgr.server.services.cel.ejb.CelServiceHome.create() throws javax.ejb.CreateException,javax.ejb.EJBException,java.rmi.RemoteException:
java.lang.SecurityException: Authentication exception, principal=controlDaemon
        at org.jboss.ejb.plugins.SecurityInterceptor.checkSecurityContext(SecurityInterceptor.java:322)
  • Information similar to the following is seen in the event.log in /opt/smarts-ncm/logs directory on the Smarts NCM AS, CS, or DS:
Nov 12 14:32:53 -1291532624#1: ======== eventdispatch pid 26376: started 9.2.1.0.48========
Nov 12 14:32:53 -1291532624#2: endPoint port is : 8881/ws/cel/services/CelPort
Nov 12 14:32:53 -1291532624#2: Interval is : 5
Nov 12 14:32:53 -1291532624#2: Load is : 50
Nov 12 14:32:53 -1291532624#2: Max tries on error : 3
Nov 12 14:32:53 -1291532624#2: username is:
Nov 12 14:32:53 -1291532624#2: CEL Service end point is : http://10.241.215.93:8881/ws/cel/services/CelPort
Nov 12 14:32:53 -1291532624#1: ->VoyenceSignal::initialize()
Nov 12 14:32:53 -1291532624#1: VoyenceSignal::initialize()->
Nov 12 14:32:58 -1291532624#1: ERROR:CEL: Username not known!!!
Nov 12 14:32:58 -1291532624#1: ERROR:EXITING!!!, check VOYENCE_HOME/conf/eventlog.ini
Nov 12 14:32:58 eventdis#1| 26376: -------- eventdispatch: stopped 9.2.1.0.48 --------
Nov 12 14:33:29 -1906350416#1: ======== eventdispatch pid 27363: started 9.2.1.0.48========


Environment

VMware Smart Assurance - NCM

Cause

This error occurs when the eventlog.ini file on the Smarts NCM DS or CS is not populated with the correct port, username, and password.

Incorrect eventlog.ini file example:

endpoint:8881/ws/cel/services/CelPort
interval:5
load:50
maxtries:3
username:
password:

Resolution

Modify the eventlog.ini file on each DS or CS as follows.
  1. Retrieve the password from the hidden file .pass.props on the Smarts NCM AS (or CS). The .pass.props file is in /$VOYENCE_HOME/conf:
[root@NCM-1 conf]# pwd
/opt/smarts-ncm/conf

[root@NCM-1 conf]# ls -al
-r--r-----  1 root voyence  128 Nov  8 09:41 eventlog.ini
-rw-rw----  1 root voyence  230 Nov  7 15:26 .pass.props

Open the .pass.props file and retrieve the controlDaemon password. The following shows an example of the password to retrieve from .pass.props file:

[root@NCM-1 conf]# vi .pass.props

#Last modified on Thu Nov 07 15:26:51 EST 2013
#Thu Nov 07 15:26:51 EST 2013
int_mod_user=duT7DfTyHu4P1n6O801fbEvPxC3OunRMx/Ssi5qh41Q\=
system=dfMRyX6wUic1R1skRQNflr+UDGSE7tk/bMzAZl+VfbU\=
controlDaemon=inDmlXM00aCV4tbcOiawFw\=\=
  1. Confirm you are in /$VOYENCE_HOME/conf directory:
[root@NCM-1 conf]# pwd
/opt/smarts-ncm/conf

 
  1. Open the eventlog.ini file in vi editor and change the port, username, and password settings as in the following:
[root@NCM-1 conf]# vi eventlog.ini

endpoint:8880/ws/cel/services/CelPort
interval:5
load:50
maxtries:3
username:controlDaemon
password:inDmlXM00aCV4tbcOiawFw\=\=