Smarts NCM: Device Server doesn't show up in the Application Server; Syntax error on line 116 of /opt/smarts-ncm/conf/httpd.conf:
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Smarts NCM: Device Server doesn't show up in the Application Server; Syntax error on line 116 of /opt/smarts-ncm/conf/httpd.conf:

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Article ID: 330963

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


Device Server installation will appear to install successfully, however the new Device Server will not show up in the Application server under Device servers.

Additionally the following errors below will be in the NCM-9.4.0.0-debug.log

Syntax error on line 116 of /opt/smarts-ncm/conf/httpd.conf:
0 :Waiting for sync...
1 :Waiting for sync...
2 :Waiting for sync...
3 :Waiting for sync...
4 :Waiting for sync...
5 :Waiting for sync...
6 :Waiting for sync...
7 :Waiting for sync..


Environment

VMware Smart Assurance - NCM

Cause

During Network Configuration Manager Device Server installation it will use port 9998 for communication to the Application Server to authenticate the certificate from the Device Server. It also appears that Uptime Agent Software also uses port 9998 for communication and if this Software is installed it will cause NCM not to install completely.

Resolution

Please complete the following steps to stop the service running on port 9998. 
  1. Log into the CLI of the device server:
  2. Run: netstat -anlp| grep 9998 to gather the process ID. 
  3. service sysadmin stop
  4. kill -9 (on the process ID found on Step 1)
  5. service voyence restart