Device Server doesn't show up in the Application Server post new installation
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Device Server doesn't show up in the Application Server post new installation

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Article ID: 330963

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Updated On:

Products

VMware Smart Assurance Network Observability

Issue/Introduction

Symptoms:

Device Server installation will appear to install successfully, however the new Device Server will not show up in the Application server under Device servers.

Additionally the following errors below will be in the NCM-<version>-debug.log

Syntax error on line 116 of /opt/smarts-ncm/conf/httpd.conf:
0 :Waiting for sync...
1 :Waiting for sync...
2 :Waiting for sync...
3 :Waiting for sync...
4 :Waiting for sync...
5 :Waiting for sync...
6 :Waiting for sync...
7 :Waiting for sync...

Environment

All Supported NCM releases

Cause

During Network Configuration Manager Device Server installation, the installer uses port 9998 for communication to the Application Server (i.e., to authenticate the certificate from the Device Server).
It also appears that Uptime Agent Software (3rd party software) also uses port 9998 for communication and if this software is installed, it may cause NCM not to install completely.

Resolution

Please complete the following steps to stop the service running on port 9998. 

  • Log into the CLI of the device server:
  • Stop the sysadmin service
service sysadmin stop
  • Run the following command to gather the process ID.
netstat -anlp| grep 9998
  • Terminate the process occupying the port 9998 obtained from the above 
kill -9 (on the process ID obtained above)
  • Start the DS services:
service voyence restart