Smarts NCM / Voyence Control: Performace issues after removing a large number of devices
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Smarts NCM / Voyence Control: Performace issues after removing a large number of devices

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Article ID: 330920

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


Users experience degraded performance in the NCM / Voyence Control Client UI after a large number of devices is removed from NCM in the NCM Client UI

Environment

VMware Smart Assurance - NCM

Cause

The NCM Client UI is considered a transactional user of the NCM PostgreSQL Control Database (controldb) where device records are stored. When a large number of devices is deleted from NCM simultaneously, the transaction based user paradigm of the NCM Client UI no longer applies because the backend processing required to purge a large number of devices from the controldb more closely aligns to a power user paradigm.

In order for NCM to simulate the performance of a transaction based paradigm in the NCM Client UI, instead of making the end-user wait for the background processing to complete, the devices are flagged for deletion. This prevents the deleted devices from being displayed or interacted with in the NCM Client UI, but does not purge their associated records from the controldb.

NCM runs a background process that purges the records for devices that have been flagged for deletion in small batches. Because a single device may have thousands of records associated with it in the controldb, this allows processing cycles devoted to purging the records from the controldb to be interspersed with the transaction based processing that is required to support normal operation of the NCM Client UI. Ordinarily, due to the small size of the batches, this background processing to purge controldb records for deleted devices goes unnoticed. However, when deleting a large number of devices, processing requirements for the many resulting batch purge operations can remain high for an extended period of time. Depending on what other operations may be pending (ex.: including, but not limited to large daily report runs in the NCM Report Advisor), high resource utilization may become noticeable to end users of the NCM Client UI.

Resolution

  1. Move devices that need to be deleted into a separate network container in NCM that will allow you to keep track of them more easily.
  2. Delete the device from the dedicated network container in small groups during periods when NCM is not experiencing peak utilization to spread the load out over a larger span of time.