Smarts NCM: Startup/ Running config not updating in the GUI following successful resync
search cancel

Smarts NCM: Startup/ Running config not updating in the GUI following successful resync

book

Article ID: 330916

calendar_today

Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


Startup/ Running config not updating in the GUI following successful resync

Following what looked like a successful pull config, we saw that the config files on the Gui were not being updated. 
After checking the commgr logs we could see the following:

Mar 23 09:30:08 -1480595712/pull(669302)#4: DASL: Chassis Model Name WS-C3750V2-24PS-S:WS-C3750V2-24PS-S:WS-C3750V2-24PS-S:WS-C3750V2-24PS-S:WS-C3750V2-24PS-S:WS-C3750V2-24PS-S

This model name has more than 100 characters and while AS is trying to insert into the Database it is facing an error as the cm_Device's vendor_model column has 100 as the size.

 


Environment

VMware Smart Assurance - NCM

Cause

As per the logs, the model name is retrieved from the EntityMIB's .1.3.6.1.2.1.47.1.1.1.1.13.1001

.1.3.6.1.2.1.47.1.1.1.1.13.2001
.1.3.6.1.2.1.47.1.1.1.1.13.3001
.1.3.6.1.2.1.47.1.1.1.1.13.4001
.1.3.6.1.2.1.47.1.1.1.1.13.5001
.1.3.6.1.2.1.47.1.1.1.1.13.6001

and these values are appended to form a Model name. Since the values are read from the MIB and it is standard approach, we can't change the driver logic.

Resolution

To resolve this issue, increase the vendor_model column in the database by following these steps:

1. Log into a Linux shell on the NCM host where the controldb is located (Application Server, Combination Server, or distributed Database Server) as 'root'.

2. Run the following command:
su - pgdba -c 'psql voyencedb voyence'

3. UPDATE pg_attribute SET atttypmod = 124 WHERE attrelid = 'voyence.cm_device'::regclass AND attname = 'vendor_model';

UPDATE pg_attribute SET atttypmod = 124 WHERE attrelid = 'voyence.cm_device'::regclass AND attname = 'vendor_model';

4. Then perform a pull all to see the latest configurations in the UI.