Smarts NCM: Nexus device pull config fails using SNMP
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Smarts NCM: Nexus device pull config fails using SNMP

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Article ID: 330911

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


Smarts NCM cannot pull config for Nexus device using SNMP

Smarts NCM Pull config for Nexus device is not completing correctly and is generating the following error:

Object [SystemProperties:SystemProperties] : Missing required element [Description] min(1)
Missing required element [MgmtAddress] min(1)
Missing required element [Model] min(1)
Missing required element [OsVersion] min(1)
[Identity] Action completed successfully...
Could not get sysName(snmpv2c:syntax(4):.1.3.6.1.2.1.1.5.0) via SNMP
Falling back to terminal access for pulling System Identity


Environment

VMware Smart Assurance - NCM

Cause

SNMP is disabled on the Cisco Nexus device.

Resolution

If SNMP is disabled on the Cisco Nexus device and cannot be enabled, you can use an SSH connection for the config pull instead.