Smarts NCM: Running backup.pl script does not update file in data-image directory even though Task Scheduler indicates that update completed successfully
search cancel

Smarts NCM: Running backup.pl script does not update file in data-image directory even though Task Scheduler indicates that update completed successfully

book

Article ID: 330906

calendar_today

Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


Smarts NCM backup.pl script does not complete update

The following conditions, events or system behaviors may be observed with this issue:
  • Running backup.pl script as a Task in Smarts NCM Task Scheduler updates that the job completed successfully, but when viewing the data-image directory, no updated file exists. 
  • Running the backup.pl script from an elevated command prompt returns the following error message:
Lock file exists.  Another backup is in progress.
To restore forcefully, delete file: C:\vcbackup.lock
 


Environment

VMware Smart Assurance - NCM

Cause

This can occur if the backup.pl script was interrupted and was not able to cleanup, leaving the vcbackup.lock file in the C:\  directory.

Resolution

To address this issue, delete the vcbackup.lock lockfile from the location indicated in the above error message (C:\vcbackup.lock in the example).