Smarts NCM: GUI Delays when users click on Auto Discovery icon
search cancel

Smarts NCM: GUI Delays when users click on Auto Discovery icon

book

Article ID: 330895

calendar_today

Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


Users will sometimes notice GUI delays when they click on Auto Discovery icon under certain networks or the default network.


Environment

VMware Smart Assurance - NCM

Cause

This is usually caused by a large amount of credentials associated with discovery templates.

Resolution

To resolve this issue do the following:
**This will require a shutdown of the Application Server which will stop all jobs and services**
  1. Log into the Application Server with root privileges. 
  2. At the command prompt run: source /etc/voyence.conf
  3. Run the following command to stop all services on the Application Server: service vcmaster stop
  4. If you are running the Report Advisor on a remote server you will need to log in as root and stop the tomcat service by running: service tomcat stop 
  5. With all the services stopped now log back into the Application Server with Root access and run the following command: service controldb start
  6. At the command prompt run: su - pgdba -c 'psql voyencedb voyence'
  7. When prompted for the database password enter it.
  8. Once inside the Database please the following commands:
VACUUM full voyence.cm_credential;
REINDEX TABLE voyence.cm_credential;
ANALYZE voyence.cm_credential;

       9. Once complete then restart all the services and test. 
      10. Another option is to log into the GUI and completely delete all the Autodiscovery templates. Refer the screen shot below.
 
Note: This step will also remove all the initial discovery jobs when the device was first created and who did them.  

.