Smarts NCM: Bulk Device import fails with the following error "Unknown exception updating config object"
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Smarts NCM: Bulk Device import fails with the following error "Unknown exception updating config object"

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Article ID: 330866

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


User tries to complete a bulk device import but errors out at the command prompt and the error message below is found in the $VOYENCE_HOME/logs/commandLineUitl.log file.  The server and powerup logs located in the $VOYENCE_HOME/ncmcore/logs directly will have no error messages, just the user logging into the bulk import tool. 



2017-12-21 11:09:16,789 ERROR [com.powerup.configmgr.util.commandline.device.ImportDevicesCmd] Error in creating new Devices
com.powerup.configmgr.deviceservice.InfrastructureCommException: Unknown exception updating config object
    at com.powerup.configmgr.deviceservice.daemon.InfrConfigAgent.writeConfigObjects(InfrConfigAgent.java:734)
    at com.powerup.configmgr.deviceservice.daemon.InfrConfigAgent.importDevices(InfrConfigAgent.java:1655)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)


Environment

VMware Smart Assurance - NCM

Cause

Incorrect formatting of the .csv file

Resolution

Do the following to resolve the issue.
  1. Open and review the csv import file
  2. Make sure your input csv import file, follows the same format as importDevices-MutliLevel.csv or importDevices-Single-Level.csv for import  (Note - an extra comma "," anywhere can make whole import fail.)
    • Examples can be found at $VOYENCE_HOME/tools/bulk-import/examples
  3. If you have a large import file, try importing 5 to 10 lines at time until you find line or section with incorrect formatting.
If the issue is still not resolved, then contact Dell EMC Technical Support and open a Service Request and reference this KB article 515793.