Adding an ESX host to vCenter Server fails with the error: Cannot install the vCenter agent service. Cannot upload agent
search cancel

Adding an ESX host to vCenter Server fails with the error: Cannot install the vCenter agent service. Cannot upload agent

book

Article ID: 330814

calendar_today

Updated On:

Products

VMware vCenter Server 7.0

Issue/Introduction

Adding the ESX host to vCenter Server fails with following error:

Cannot install the vCenter agent service. Cannot upload agent

In the /var/log/vmware/hostd.log file of the ESX host, you see a warning similar to:

[<YYYY-MM-DD><time> F59DEB90 warning 'Proxysvc Req00043'] Connection to named pipe /var/run/vmware/proxy-vpxa failed with error N7Vmacore15SystemExceptionE(Connection refused).</time>
In the vpxd.log file of vCenter Server, you see errors similar to:
[<YYYY-MM-DD><time></time> 01892 error 'App' opID=B5C87B14-00000484] [VpxNfcClient] Unable to connect to NFC server: Failed to connect to server 192.168.0.150:902
[<YYYY-MM-DD><time></time> 01892 error 'App' opID=B5C87B14-00000484] [VpxdHostAccess] Failed to upload files: vim.fault.HostConnectFault
[<YYYY-MM-DD><time></time> 05948 info 'Libs' opID=53CAD942-0000022A] Cannot connect to server name:902: No connection could be made because the target machine actively refused it
[<YYYY-MM-DD><time></time> 05948 info 'Libs' opID=53CAD942-0000022A] Cnx_Connect: Returning false because CnxConnectAuthd failed
[<YYYY-MM-DD><time></time> 05948 info 'Libs' opID=53CAD942-0000022A] Cnx_Connect: Error message: Failed to connect to server name:902
[<YYYY-MM-DD><time></time> 05948 error 'App' opID=53CAD942-0000022A] [VpxVmdbCnx] Authd error: Failed to connect to server name:902

Environment

vCenter Server 7.0.x

 

Cause

This issue occurs if port 902 is blocked or is in use by another application. vCenter Server requires TCP port 902 for uploading the vpxa agent to the ESX host.

Resolution

To resolve this issue, ensure that you can telnet TCP port 902 from vCenter Server to the ESX host. For more information, see Testing port connectivity with Telnet (1003487).

Also, ensure that the firewall or antivirus software is not blocking port 902.

Note: In some instances it may be found that port 902 is open and responding as expected. The issue may then be occurring as a result of the / partition on the ESX host being full. In this instance an error message similar to the following may be reported in the hostd.log.

[<YYYY-MM-DD> info 'Libs'] [NFC DEBUG] NfcFileRawRead: write error There is no space left on the device.
[<YYYY-MM-DD> warning 'Libs'] [NFC ERROR] NfcFile_ContinueReceive: write failed. expected 262144, got -1
[<YYYY-MM-DD> info 'Libs'] [NFC DEBUG] NfcFile_Delete: Deleting file '/tmp/vmware-root/ha-agentmgr/upgrade '
[<YYYY-MM-DD> warning 'Libs'] [NFC ERROR] NfcServerLoop: failed to receive file data
[<YYYY-MM-DD> error 'Nfc'] Nfc_AuthdServerLoop saw error: File error -- Failed to write to the target file : There is no space left on the device

To resolve the issue in this instance, free the necessary space on the ESX/ESXi host.

Additional Information

For related information, see Required ports for configuring an external firewall to allow ESX/ESXi and vCenter Server traffic (1005189).

Hosts with the scratch configuration pointing to an invalid datastore may report the error:

Cannot install the vCenter agent service. Cannot upload agent

To resolve this issue, see
port connectivity with Telnet
Required ports for configuring an external firewall to allow ESX/ESXi and vCenter Server traffic
"Heap globalCartel-1 already at its maximum size” error in ESXi host