Usage Meter 3.5 stops collecting data from an active vCenter Server without any errors
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Usage Meter 3.5 stops collecting data from an active vCenter Server without any errors

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Article ID: 330629

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • vCenter Server is active in Usage Meter
  • There are no errors of collections on the Monitor tab of Usage Meter
  • vCenter Server in question has a VCAN License under the Licenses tab
  • On the Rules tab vCenter Server in question is not present
  • vCenter Server in question is missing in all reports
  • Virtual machines that have been deleted or shut off appear as on in the virtual machine History report


Cause

The EventsMonitor collector experiences a failure from either an earlier failure. This failure can be from the current month or at any point in the virtual appliance's current power state. This causes the tomcat service to exhibit erroneous behavior.

Resolution

To resolve this issue:
  1. Access the command line of Usage Meter either by the popout console (through vSphere) or by SSH. Confirm that the timezone is set and is correct.
  2. In the command line, run this command: service tomcat restart.
  3. Log in back to the web GUI of Usage Meter 3.5.
  4. On the Manage tab, click the Synchronize All vCenter Inventories button.
Otherwise, upgrade to Usage Meter 3.6.x. This version of Usage Meter has a longer time to failure as it runs this script on a chron job: /opt/vmware/cloudusagemetering/scripts/umhealth.sh. However this script can still enter a fail state, and the entire appliance will fail once again. This will be fixed in a future release of Usage Meter.

Additional Information

Impact/Risks:
This can ruin the reliability of Usage Meter and cause at least two months of inaccurate reporting.