Route table max entries failure
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Route table max entries failure

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Article ID: 330536

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Updated On:

Products

VMware NSX

Issue/Introduction

Title: vmc_app.tgw_route_table_max_failure
Event ID: vmc_app.tgw_route_table_max_failure

Alarm Description

  • Purpose: TGW route capacity limit is reached which results in failure.
  • Impact: New route programing will fail which will have network connectivity issue on new networks.

Environment

VMware NSX-T Data Center

Cause

When number of routes in the route table reaches max limit, no new routes can be added.

Resolution

Steps to resolve

For 4.1.2.0 and higher

Recommended Actions:

  1. Login to NSX manager UI in 'Networking & Security' tab. Then navigate to 'transit connect' tab.
  2. Check if 'learned routes' page contains a route with 'Failure' status. Check if the failure is due to reaching route table limits.
  3. Login to ESX host and run 'vmc-cli -s'. Note down the onprem table id and egress route table id.
  4. If failure is due to route table limits, then do the following:
    1. Check the number of route failures due to route table limits in 'learned routes' tab.
      This is the minimum number to which the route table limits should be increased. Lets call this threshold.
    2. Create AWS support request to increase the VPC route table limit to a minimum of threshold value.
      The VPC route table can only be increased upto 1000 entries(AWS hard limit).
      Recommendation is to increase the limits to more than the threshold.
    3. Once the AWS route table limits are increased, check 'learned routes' tab to find out if all the failures related to route table limits are eliminated.

Maintenance window required for remediation? No