Purpose:VMC App cannot program AWS managed prefix list with route/prefix because number of entries in AWS managed prefix list has reached size of the prefix list.
Impact: This issue is only specific to SDDCs with direct connect connectivity enabled. On SDDCs which direct connect is not yet enabled (i.e. no VIF is being attached), SDDC cannot advertise any network over direct connect.
Environment
VMware NSX
Cause
When number of prefixes in AWS managed prefix list reaches size of prefix list, no new segments can be added again.
Resolution
Steps to resolve
For 4.1.2 and higher
Recommended Actions:
Run API GET 'cloud-service/api/v1/infra/sddc/provider-resource-info?resource_type=managed_prefix_list' to get a list of all prefix lists from SDDC.
Check the 'state' and 'status_message' of each prefix list in API output.
If the state of any prefix list is 'modify-failed' and status message has the string 'The following VPC Route Table resources do not have sufficient capacity' then the prefix list has run into resizing failure. The 'status-message' is going to specify what route table Ids have to be increased in size.
If the API output contains 'issues' field, it would specify what routes are missing from the managed prefix list. Calculate number of routes missing from 'issues' field.
File a AWS ticket to increase size of the routing table identified in (b) by at least minimum size identified in (c).
After AWS increased the route table limit, wait for at least 1 hour and then invoke API' GET 'cloud-service/api/v1/infra/sddc/provider-resource-info?resource_type=managed_prefix_list'. Make sure 'state' of any of the prefix list is not 'modify-failed'.