'Cluster is not homogenous in terms of VDS connections or physical adaptors' because 'Standby uplink list must be empty for LOADBALANCE_SRCID teaming policy' on dvportgroups
search cancel

'Cluster is not homogenous in terms of VDS connections or physical adaptors' because 'Standby uplink list must be empty for LOADBALANCE_SRCID teaming policy' on dvportgroups

book

Article ID: 330525

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

  • When performing a new NSX-T deployment on a cluster through the NSX-T Plugin in vSphere, the following error is seen:
    'Cluster is not homogenous in terms of VDS connections or physical adaptors. Please select another cluster or attach a common VDS(7.0 or higher) to all hosts within this cluster.'


  • After logging in to NSX Manager UI, navigate to:
    • System > Quick Start.
    • On the Prepare Clusters for Networking and Security card and click Get Started.
    • Select the clusters where you want to activate distributed security.
    • Click Install NSX and under Networking, choose either VLAN or Overlay.

      This is where you see the error:
      Error: Standby uplink list must be empty for LOADBALANCE_SRCID teaming policy associated with dvportgroup-xx. Please modify the teaming policy from VSphere and retry the Quick Install workflow. Alternatively, please use the advanced host switch configuration workflow. (Error code:610506)
  • Both of which will make it so you cannot select the VDS on the cluster and continue the installation

 

Environment

VMware NSX

Cause

This is caused by dvportgroups that are configured for load balance_srcid with a standby uplink. NSX requirement that this configuration cannot exist on the cluster in which NSX is being installed upon

Resolution

To correct the configuration, follow these steps:

  1. Log in to the vSphere Client.

  2. Navigate to Networking and locate Distributed Virtual Portgroups with Route based on originating virtual port configured
  3. Right-click the portgroups and select "Edit Settings."

  4. In the Edit Settings window, go to the "Teaming and failover" section.

  5. Under "Load balancing," ensure that "Route based on originating virtual port" (LOADBALANCE_SRCID) is selected.

  6. Clear the "Standby uplinks" list. For the LOADBALANCE_SRCID teaming policy, there should be no standby uplinks defined.

  7. Click "OK" to save your changes.

  8. Retry the NSX-T Quick Install workflow or the advanced host switch configuration workflow, as suggested in the error message and if that is the only issue the install should continue as expected