TGW Tagging Mismatch failure alarm
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TGW Tagging Mismatch failure alarm

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Article ID: 330495

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Updated On:

Products

VMware NSX

Issue/Introduction

Title: vmc_app.tgw_tagging_mismatch_failure
Event ID: vmc_app.tgw_tagging_mismatch_failure

Alarm Description

  • Purpose: Failure due to mismatch of TGW tags.
  • Impact: Learned TGW route might be missing some important fields.

Environment

VMware NSX

Cause

This issue can happen if Skynet did not create the prefix list with the correct tags.

Resolution

Steps to resolve

For 4.1.2.0 and higher

Recommended Actions:

If this alarm is not auto-resolved within 10 minutes, then execute the following steps:

  1. Find out the number of TGW prefix lists in VMC-APP. Please follow below steps:
    1. Run the API 'GET cloud-service/api/v1/infra/associated-groups'.
      Please note down all the TGW prefix list Ids listed under 'aws_prefix_list'.
    2. For each prefix list obtained in the above API, check if the managed prefix list contains all the required tags.
      Please check whether there are missing tags in AWS prefix list. Each attachment type requires different set of tags.
      All the tags required for each attachment type is mentioned below:

           SDDC
           SDDC_ID: &ltSDDC id>
           RESOURCE_ID: &ltSDDC id>
           RESOURCE_TYPE: SDDC
           GROUP_ID: &ltgroup id>
           RESOURCE_REGION: &ltSDDC region>

           VPC
           RESOURCE_ID: &ltvpc id>
           RESOURCE_TYPE: VPC
           GROUP_ID: &ltgroup id>
           RESOURCE_REGION: &ltVPC attachment region>

           CUSTOMER_TGW
           RESOURCE_ID: &ltTGW id>
           RESOURCE_TYPE: CUSTOMER_TGW
           GROUP_ID: &ltgroup id>
           RESOURCE_REGION: &ltTGW attachement region>

    3. If any tag is missing from any prefix list, Please contact [email protected] and Srikanth Garimella.
      Please provide SDDC group ID, prefix list ID and its region.

  2. After Skynet team identified/confirmed that issue is valid, manually add correct tags using AWS console.

Maintenance window required for remediation? No