Service instances become Unknown status after re-registering vCenter Server
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Service instances become Unknown status after re-registering vCenter Server

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Article ID: 330491

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Updated On:

Products

VMware NSX

Issue/Introduction

Symptoms:
  • Any Service deployments cannot be seen through Manager Web UI.
  • Service instances' Deployment and Health Status is Unknown.
  • 3rd vendor security solution works properly.
  • NSX-T version is earlier than 3.1.0.


Environment

VMware NSX-T Data Center

Cause

  • Managers cannot recognize vCenter Server correctly after re-registering.
  • Service Instances' objects are associated with old vCenter Server.

Resolution

Remove service instances as follows and deploy new service instances.

  1. Delete existing service deployment. Execute following command in Manager with root.
    # curl -k -u admin:<password> -X DELETE https://localhost/api/v1/serviceinsertion/services/<service_id>/service-deployments/<deployment_id>
  2. Check there is no service deployments or service instances.
    # curl -k -u admin:<password> -X GET https://localhost/api/v1/serviceinsertion/services/<service_id>/service-deployments
    # curl -k -u admin:<password> -X GET https://localhost/api/v1/serviceinsertion/services/<service_id>/service-instances
  3. Access to https://<VC_IP_or_FQDN>/eam/mob/?moid=<agency_moid>  with administrator. agency_moid is for 3rd vendor security solution. Determine target agency by its config.
  4. Execute [Uninstall] > [Invoke Method] and confirm all SVMs are deleted.
  5. Execute [DestroyAgency] > [Invoke Method]  and confirm its agency is deleted.
  6. Deploy new service instances through Manager Web UI.



Workaround:
There is no workaround. This problem is fixed in NSX-T 3.1.0.

Additional Information

Impact/Risks:
  • Service instances' Deployment and Health Status cannot be recognized correctly and resolve button doesn't show up in Manager Web UI.
  • Service instances cannot be deleted through Manager Web UI.