Prefix list resource share customer failure alarm
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Prefix list resource share customer failure alarm

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Article ID: 330443

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Updated On:

Products

VMware NSX

Issue/Introduction

Title: vmc_app.prefix_list_resource_share_customer_failure
Event ID: vmc_app.prefix_list_resource_share_customer_failure

Alarm Description

  • Purpose: Failure with prefix list resource share.
  • Impact: The connected VPC prefix lists shared to the customer will no longer be accessible.

Environment

VMware NSX-T Data Center

Cause

Customer accidentally or intentionally clicks on (Leave resource share) in the customer account, this alert would be raised.

Resolution

Steps to resolve

For 4.1.2 and higher

Recommended Actions:

If this alarm is not auto-resolved within 10 minutes, then execute the following steps:

  1. Get the current resource share ARN that is shared with the customer connected VPC account by running the following command.
    1. curl -ik -X GET https://<nsx-mgr-vip>/cloud-service/api/v1/infra/linked-vpcs resource-share-arn → this is the resource share which is shared with customer account. Make sure it is in ACTIVE state. There should not be a case where its not active.
    2. Run the following AWS command to get the current status of the resource share. Use the 'resource-share-arn' fetched in step1. The AWS CLI command can either be run from NSX manager console or any other platform where AWS CLIs can be run:
      • /usr/local/bin/aws ram get-resource-share-associations --association-type PRINCIPAL --resource-share-arns arn <resource-share-arn> --region <region>
        • resource-share-arn - fetched in a)
        • region - AWS region where SDDC is deployed.
        • If the resource share status is ASSOCIATED, then nothing needs to be done.
        • If the resource share status = DISASSOCIATED, then issue needs to be remediated as follows:
        • Inform the customer that he has accidentally left the resource share.
        • If customer mentions that he does not want to use prefix list mode again, then ask the customer to disable prefix mode from connected VPC UI.
        • If the customer mentions that he wants to be remediated and still use prefix list mode, ask the customer to disable prefix list mode from the UI.
      • After this is successful, ask the customer to enable prefix list mode again.

Maintenance window required for remediation? No