TGW Attachment failed to get failure alarm
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TGW Attachment failed to get failure alarm

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Article ID: 330436

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Updated On:

Products

VMware NSX

Issue/Introduction

Title: vmc_app.tgw_get_attachment_failure
Event ID: vmc_app.tgw_get_attachment_failure

Alarm Description

  • Purpose: Failure in fetching TGW attachment.
  • Impact: SDDC group route exchange will be stoped with this issue so SDDC will not able learned new routes adverted from other SDDC/external members and advertised new route to the SDDC group.



Environment

VMware NSX-T Data Center

Cause

Background TGW routes update task failed to get TGW attachment related info. Possibilities of hitting this alert is very low, except regression in service or AWS side.

Resolution

Steps to resolve

For 4.1.2.0 and higher

Recommended Actions:

If this alarm is not auto-resolved within 10 minutes, then execute the following steps:

  1. Log in to nsx manager. There are three manager nodes, we will need to find the leader node.

    After logging in to one node, run commands:

    su admin
    get cluster status verbose

    Find out the TGW Leader node.

  2. Please check if all AWS calls from nsx manager failed.
    1. Log in to nsx manager leader node and run following commands:

      export HTTPS_PROXY=http://<pop ip>:3128
      aws ec2 describe-instances --region <region>

    2. If aws command failed with error, then there might be a system issue in HTTP reverse proxy configuration on pop, or there is AWS service side issue.
  3. Please check whether TGW attachment still exists in AWS.
    1. TGW attachment ID could be found by running following API 'GET cloud-service/api/v1/infra/associated-groups'.
      tgw_attachment_id -> TGW attachment id.

    2. Run the following CLI from NSX manager console:

      aws ec2 describe-transit-gateway-attachments --region <region> --transit-gateway-attachment-id <TGW attachment ID>

    3. If TGW attachment does not exist, there will be error message

      'An error occurred (InvalidTransitGatewayAttachmentID.NotFound) when calling the DescribeTransitGatewayAttachments operation: Transit Gateway Attachment tgw-attach-0db05afa627b82f08 was deleted or does not exist.'

    4. If TGW attachment has been deleted, please contact Skynet team [email protected] (Srikanth Garimella).

      Please share SDDC ID and TGW attachment ID.

Maintenance window required for remediation? No