Logging in to vCenter Server Appliance 6.5 fails with the error: Unable to authenticate user. Please try again.
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Logging in to vCenter Server Appliance 6.5 fails with the error: Unable to authenticate user. Please try again.

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Article ID: 330332

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:

  • Virtual Appliance Management Interface (VAMI) login using <https://VC_FQDN/IP:5480> fails for "root" user with following error:
    • Unable to authenticate user. Please try again
  • Login to SSH is successful for "root" user.
  • Sample log snippet in /var/log/vmware/applmgmt/vami.log
    YYYY-MM-DD HH:MM:SS [53107]ERROR:session_management:Session Available check failed: No JSON object could be decoded
    Traceback (most recent call last):
      File "/opt/vmware/share/htdocs/vami/backend/session_management.py", line 113, in sessionsAvailable
        cls.expiredSession(ConfigManager(f))):
      File "/usr/lib/applmgmt/base/py/vmware/vherd/base/config_manager.py", line 25, in __init__
        object_hook=lambda d: defaultdict(ConfigManager.defaultFactory, d))
      File "/usr/lib/python2.7/json/__init__.py", line 291, in load
        **kw)
      File "/usr/lib/python2.7/json/__init__.py", line 352, in loads
        return cls(encoding=encoding, **kw).decode(s)
      File "/usr/lib/python2.7/json/decoder.py", line 364, in decode
        obj, end = self.raw_decode(s, idx=_w(s, 0).end())
      File "/usr/lib/python2.7/json/decoder.py", line 382, in raw_decode
        raise ValueError("No JSON object could be decoded")
    ValueError: No JSON object could be decoded
    YYYY-MM-DD HH:MM:SS [53107]ERROR:root:Structure('LocalizableMessage', dict(defaultMessage='The maximum number of sessions has been reached', args=[], id='com.vmware.applmgmt.admind.authenticate.max.session'))

     

Cause

This is caused by a file corruption in the following location of the vCenter Server:

/var/vmware/applmgmt/session/XXXX

Resolution

The issue is fixed in version 6.5 U2.

The following workaround can be followed for versions lower than that:

  • Delete all the files in the following location of the vCenter Server:
    /var/vmware/applmgmt/session/
  • Reload the VAMI page and try to login using "root" credentials.