Virtual Machines in a Missing status in VMware Aria Automation 8.x
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Virtual Machines in a Missing status in VMware Aria Automation 8.x

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Article ID: 330182

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

  • You have recently migrated to a new vCenter that was added as a Cloud Account in Aria Automation.
    • This new vCenter has a new name or was redeployed.
  • You are migrating virtual machines between vSphere datacenter clusters that are defined as Cloud Zones in Aria Automation.
  • VM status in Aria Automation is Missing.
  • Another VM with the same name is in Discovered status.

Environment

VMware Aria Automation 8.x

Cause

This issue occurs if the virtual machine's Managed Object Reference (MoRef) changes in vCenter. A MoRef can change under different circumstances, such as:
  • VM is migrated to another vCenter.
    • Cross-vCenter vMotion*
  • VM is migrated within the same vCenter.
  • VM is restored from a backup.
  • VM has been moved by a DR event or a migration tool such as SRM or HCX.

Resolution

  • This is an expected behavior.
  • VMware is working on improving this functionality in future releases.

Workaround

Re-onboard the virtual machine into VMware Aria Automation.
For more information, see Example: Onboard selected machines as a single deployment in Cloud Assembly.

Note: After onboarding, only simple day 2 operations will be available. Relationships with other components such as custom resources, networks, and storage volumes may not be available.

Additional Information

  • There is no out-of-the-box Day 2 Action to Migrate virtual machines deployed by Aria Auto 8.x to a different vCenter.
  • There is no out-of-the-box Day 2 Action to vMotion systems internally within the same vCenter for virtual machines deployed by Aria Auto 8.x

VMware recommends to not perform any changes to deployed virtual machines outside the scope of VMware Aria Automation.

Available Day 2 Actions for Deployments can be checked with steps below: 

  1. Navigate to Service Broker > Content & Policies > Definitions > Actions > Show More
    1. This will display all Day 2 Actions available