[VMC on AWS] NSX UI fails to load on 1.22 SDDC
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[VMC on AWS] NSX UI fails to load on 1.22 SDDC

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Article ID: 329976

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Updated On:

Products

VMware Cloud on AWS

Issue/Introduction

Detail the known issue affecting these symptoms.

Symptoms:

After deploying or upgrading an SDDC to the 1.22 version, the NSX UI (Standalone UI as well as the Networking & Security Tab UI) will fail to load.

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The index.html call stops with an HTTP 304 and fails to load further upon inspection.

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The web browser being used has a language default other than the officially supported NSX-T languages.


Cause

This is caused by a known problem in the 1.22 SDDC version wherein the localization redirect to the default of English fails.

Resolution

VMware is aware of the issue and will include a fix to this problem in an upcoming 1.22 minor version (v release).

Workaround:

Change the browser's language to default to one of the officially supported languages, English for example.

 


Additional Information

Impact/Risks:
The customer will be unable to load the NSX UI if their web browser is set to default to any language other than the officially supported languages for NSX-T.

NSX-T officially supports the following:
English, German, French, Japanese, Simplified Chinese, Korean, Traditional Chinese, Italian, and Spanish