[VMC] Unable to access services in the SDDC after an SDDC upgrade
search cancel

[VMC] Unable to access services in the SDDC after an SDDC upgrade

book

Article ID: 329950

calendar_today

Updated On:

Products

VMware Cloud on AWS

Issue/Introduction

  • The SDDC has been recently upgraded.
  • After the upgrade, once accessible services can no longer be reached.
  • When viewing the "Rule Hits Statistics" for the firewall rule, the Hits and Sessions count is zero (0).
  • The logs do not show any traffic hitting the firewall rule.
  • The firewall rule was disabled during the upgrade and enabled after the upgrade completed. 
  • Modifying the firewall rule does not resolve the issue.

Environment

VMware Cloud on AWS

Cause

  • This is caused by the rule being disabled during the SDDC upgrade.
  • Previously disabled rules will continue to be disabled on NSX even if they are showing as enabled in the UI. 

Resolution

There is currently no resolution to this known issue.

Workaround:
There are two workarounds for this issue. 

  1. Clone the affected firewall rule. 
    1. Verify the affected firewall rule is "Enabled". 
    2. Click on the firewall rule and select "Clone". 
    3. Once cloned, name the rule and keep the rule "Enabled". 
    4. The originally problematic firewall rule can be deleted once the new rule has been verified to work. 
  2. Create a new firewall rule with the required settings. 
    1. To create a new rule, follow the process documented in Add or Modify Compute Gateway Firewall Rules .
    2. Once the new rule has been created, the affected rule can be deleted.