[VMC on AWS] Workload VM fails to power on after attempted vSphere HA Restart
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Article ID: 329799
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Updated On:
Products
VMware Cloud on AWS
Issue/Introduction
Explain the technical resolution to this issue to unblock customer's critical workload VMs.
Symptoms: The Workload VM is unable to power on via vSphere HA. vSphere HA will trigger a warning at the VM level stating that there are insufficient resources to fail over the workload VM.
The specific workload VM has a vNIC connected which is displaying as "none" within the vCenter UI.
When the workload VM is powered on initially, outside of the vSphere HA workflow, the VM will report one of its Virtual Devices as disconnected at start.
Cause
The workload VM has a vNIC connected which is referencing an invalid network. This invalid vNIC will display as being connected to "none" within the vSphere UI.
Resolution
Remove the offending vNIC from the workload VM's configuration:
Right click the target workload VM > Edit Settings
Remove the offending vNIC by Clicking the X on the right side of the invalid/disconnected vNIC device.
Click Okay to confirm changes
Additional Information
Impact/Risks: There are minimal impacts to this resolution as the tasks can be carried out while the workload VM remains powered on.