You are likely to see this problem on your On-Prem Vcenter, when you are accessing inventory objects from the cloud UI (VMC vcenter side).
The user/group has been assigned permissions via a custom role created on On-Prem deployment .
When you directly login into the On-Prem Vcenter (On-Prem UI), and validate the group/user is able to access and perform operations on the inventory object.
Cause
This problem arises with custom roles and permissions. HLM does not replicate roles and permissions from the On-Prem to the Cloud Vcenter. Any privileges given via a custom role is not processed cause the cloud VC does not have the same role and permissions defined.
Resolution
VMware is aware of this issue and working to resolve this in a future release
Workaround:
Contact VMWare Technical Support to have an SRE create a custom role on Cloud VC with the same privileges as on the On-Prem custom role. Ensure the permissions and the name of the custom role match exactly.You can assign privileges to a user via a Pre-define role in Vcenter. Please do not use the custom role until the fix is rolled out.